ERAs are being delivered with DXC's claim number instead of the provider's claim number

Incident Report for DentalXChange Product

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 21:44 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2026 - 21:01 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 10, 2026 - 15:53 PDT

Investigating

We are informing all clients that we are currently experiencing an issue with ERAs displaying DXC's claim number instead of providers claim number. This issue is limited to only some ClaimConnect accounts. Our team is engaged and addressing the issue. Please note this is not a cybersecurity Incident.
Posted Aug 10, 2026 - 13:46 PDT