Channel Partners Reporting They Are Not Receiving Emails from DXC

Incident Report for DentalXChange Product

Resolved

For the Channel Partners that reported the issue, the emails were confirmed delivered and accepted on their end, pointing to quarantine on their side. We are closing the incident with no issues found on our side, as email flow has been confirmed working.
Posted Sep 09, 2026 - 08:14 PDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 08:00 PDT

Investigating

We are informing all clients that we are currently experiencing an issue with Channel Partners receiving emails from DXC. Our team is engaged and addressing the issue. Please note this is not a cybersecurity Incident.
Posted Sep 09, 2026 - 07:21 PDT
This incident affected: DentalXchange.com.