XConnect and ElibilityAI issues

Incident Report for DentalXChange Product

Resolved

This incident has been resolved. A Post Incident Report will be made available during the week of 3/23.
Posted Mar 18, 2026 - 12:18 PDT

Monitoring

Issue was identified, fix was implemented and we are monitoring to ensure continued stability.
Posted Mar 18, 2026 - 11:34 PDT

Investigating

EligibilityAI checks are not working and XConnect API servers are failing. Teams are investigating.
Posted Mar 18, 2026 - 10:33 PDT
This incident affected: API Services (XConnect - Accounts, XConnect - Attachments, XConnect - Claims, XConnect - Enhanced Eligibility, XConnect - Eligibility, XConnect - Payment, XConnect - Statement) and Eligibility AI.