Internet Outage Impacting Inbound and Outbound Communication from DentalXChange Data Center

Incident Report for DentalXChange Product

Resolved

The internet outage, impacting both inbound and outbound communication from our data center, has been resolved.

We appreciate your patience and understanding as we worked closely with our service provider to identify the root cause and restore full connectivity.
Posted Dec 10, 2025 - 08:26 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 06:35 PST

Investigating

We are currently experiencing an internet outage impacting both inbound and outbound communication from our data center. While all internal systems remain fully functional and operational, they are currently inaccessible externally via the internet.

The issue began around 5:00 AM PST, and our team is actively monitoring the situation to ensure continued system stability and service continuity.

We appreciate your patience and understanding as we work closely with our service provider to identify the root cause and restore full connectivity.
Posted Dec 10, 2025 - 05:18 PST
This incident affected: CustCare (CustCare /CustCare, CustCare /CHSupport, CustCare /DCIApprover).